Back to overview
Degraded
Degraded performance of B2C customer search
May 5, 2026 at 9:01am UTC
Affected services
ERP Web Application
Resolved
May 5, 2026 at 9:26am UTC
The issue has been fixed and performance has returned to normal.
Affected services
Updated
May 5, 2026 at 9:21am UTC
We have identified the root cause of this issue and a fix is being rolled out. We'll continue to monitor the performance.
Affected services
Created
May 5, 2026 at 9:01am UTC
Our internal monitoring has diagnosed degraded performance of B2C customer queries in all surfaces.
We're investigating this issue.
Affected services