Back to overview
Resolved
Degraded performance of creation of shipments
Aug 19, 2026 at 11:10am UTC
Affected services
ERP Web Application
Resolved
Aug 19, 2026 at 11:55am UTC
The issue is now resolved and shipments can be created without slowdowns.
Affected services
Updated
Aug 19, 2026 at 11:49am UTC
A fix is now being rolled out as we continue to monitor the performance of the system.
Affected services
Updated
Aug 19, 2026 at 11:38am UTC
We have identified the root cause of the issue and expect to have a fix deployed soon.
Affected services
Created
Aug 19, 2026 at 11:10am UTC
There is currently an active issue where creating new shipments is slow and will occasionally time out.
We're actively investigating the issue and working to ship a fix.
Affected services